·
All services have been restored.
No components marked as affected
Resolved
Identified
We have identified the issue and are deploying a fix.
Investigating
Major Impact to user login and incorrectly directing customers to billing